Shapes

Drawing Shapes

Rectangles

Choose the tool, click on the frame and drag to draw a rectangle

Squares

Choose the tool, hold Ctrl, click on the frame and drag to draw a square

Ellipses

Choose the tool, click on the frame and drag to draw an ellipse

Circles

Choose the tool, hold Ctrl, click on the frame and drag to draw a circle

Rounded Rectangles

Choose the tool, click on the frame and drag to draw a rectangle. Choose "Item" > "Edge Rounding" and enter the radius, click OK. The rectangle looks better if the outline is 2 or more pixels wide

To change the width and the color of the outline

Select the shape and choose "Item" > "Line Width" and "Line Color"

See also: Gradient Fill

See also: Bitmap (Texture) Fill

Drawing Lines

Straight Lines

Choose the tool, click on the frame and drag to draw a straight line

Horizontal or Vertical Lines

Choose the tool, hold SHIFT, click on the frame and drag to draw a straight line

Curves

Draw a straight line as above, select the tool, right click on the end node and choose "To Curve". The control node should appear, drag the handle to shape the line. You can also hold Ctrl when adding lines to existing shape.

Stars, Hexagons and other shapes

Choose "Insert" > "Shape or Line" and select one of the items to insert

Creating Text Shape

Choose "Insert" > "Text Shape", enter the text and click OK

Node Editing

To edit existing polyline nodes choose the tool. Select a polyline to edit. Right click on a node so one of the segments gets bolder. Then choose "Insert", "Delete", "To Curve" or "Straighten" command from a popup menu.

Converting a line to a curve

Right click on the node ending the line and choose "To Curve"

To shape a curve

Choose the tool and drag the control node of the curve.

Straightening a curve

Right click on the node at the end of the curve and choose "Straighten"

To remove a node

Right click on the node and choose "Delete"

To add a node

Right click on the node at the end of the line where a new node should appear and choose "Insert"

Breaking the node

Right click on the node and choose "Break". Drag the broken node to a new position.

Moving the node

Choose the tool and drag the node

Moving multiple nodes

Choose the tool and drag a rectangle around nodes to select multiple nodes. Drag one of the selected nodes to move them.

Removing the node

Right click on the node and choose "Delete"

To close an open line

Select the line with the tool, choose the tool and draw a line between the end nodes.

To join 2 separate lines

Select both segments with tool and choose "Edit" > "Combine Shapes" command. Select the tool and draw a line between the end nodes of each subpath.

To combine segments

Select 2 or more shapes (1) and choose "Edit" > "Combine Shapes" to create combined shape (2).

To break multisegment line

Select the line and choose "Edit" > "Break Apart" command.

Drawing freehand shape

Choose the tool, click on the frame and drag the mouse to draw a shape.

Tracing

Import a bitmap to trace. Choose the tool and click inside a solid area of the bitmap to create a vector shape. The magic wand tool has a tolerance of 1 pixel.

Clipping Path

A clipping path creates a mask and masks items ABOVE it (to clip an item put the clipping path below the item to clip with Edit > Send to Back)

The following example shows 7 circles clipped by mouth shape.


clippath.sfd

To change clipping options double click the shape, check "Clip Shape" and specify how many items above the path should be clipped.


no clipping

clip count: 1

clip count: 2