Items and Layout

Each frame may contain one or more items.

Shapes Images Texts Buttons Sprites

Use the "Select" tool to select, move, align and duplicate items.

Selecting a single item

Click on an item to select it. To deselect the item click outside the item.

When one item is selected press TAB key to select the next item. Press SHIFT+TAB to select the previous item.

Selecting 2 or more objects

Choose the "Select" tool and draw a rectangle around items you want to select

or Hold SHIFT key and click the item to add it to (or subtract it from) the selection.

Duplicating Items

To duplicate item(s) hold CTRL and move the item to create a copy.

or

Select the item and choose Edit > Duplicate. Specify the position of the new item and click OK. Change count value to create more than one copy.

Positioning Items

Drag the item(s) with the "Select" tool. Observe the status bar to view the distance.

Moving an item vertically or horizontally

Start dragging the item and hold SHIFT key to move the object horizontally or vertically.

Precise Positioning

Select items and use arrow keys to move items by 1 pixel left, up, right or down. Hold SHIFT and press arrow keys to move items faster (by 10 pixels)

Use Edit > Move To command to place the item at x (horizontal) and y (vertical) coordinate. The top-left edge of the frame is at 0,0 coordinate.

Use Edit > Move By to move items by x (right) and y (down) pixels

Grid Positioning

Choose View > Grid and check "Enable Grid". The default grid is 10 x 10 pixels. When you move any item it will snap to the grid.

Aligning Objects

To align an item to the page edge

select the item and choose one of Edit > Align commands

To center the item on the page

select the item and choose Edit > Align > Center on Page

Use shortcut buttons to align items faster

Inserting rulers

right click inside the frame area and choose Insert Horizontal Ruler or Insert Vertical Ruler or choose "Insert" > "Rulers" to add 2 rulers at the center of the page.

Moving rulers

choose the "Select" tool and drag the ruler or right click on the ruler and choose Move command.

Removing rulers

right click on the ruler and choose Delete command

Sizing Objects

Select the item and choose Item > Resize. Enter new size of the item. Uncheck Keep proportions to discard aspect ratio.

or

Select the item and drag one of its handles

To fit the item to frame

To resize the item to cover the entire frame select the item and choose Edit > Align > Fit to Frame

Rotating Objects

To specify the angle at which the item will be exported to Flash Player choose Item > Rotate > Angle. This rotation is not visible in the design mode. Press F9 to preview the item.

To rotate the item so you can edit it later select the item and choose one of the Item > Rotate > commands. Only bitmap and polyline objects can be rotated.

Rotation over a point

To rotate an item around a point select it and choose Item > Rotate > Rotate Arbitrary:

Check Leave Original and enter iteration count (the number of copies). Calculate necessary angle (full circle is 360 degrees so rotate = 360 / (iterations + 1) ). Enter positive Y to rotate around the point below the item or positive X to rotate around the point to the right. You can experiment with the following values:

Rotate: 90, Iterations: 3
Rotate: 72, Iterations: 4
Rotate: 60, Iterations: 5
Rotate: 51, Iterations: 6
Rotate: 45, Iterations: 7
Rotate: 40, Iterations: 8
Rotate: 36, Iterations: 9
Rotate: 33, Iterations: 10
Rotate: 30, Iterations: 11
Rotate: 28, Iterations: 12
Rotate: 26, Iterations: 13
Rotate: 24, Iterations: 14
Rotate: 22, Iterations: 15

Mirroring Objects

Select the item and choose Item > Placement Properties. Check Flip Horizontal or Flip Vertical option. Mirroring is exported to Flash Player and it is not visible in the design mode. Hit F9 to preview.

To mirror the item so you can edit it later select the item and choose Item > Rotate > Flip command. Only bitmap and polyline objects can be mirrored.

Grouping Items

When you group 2 or more items you can move them as a single unit. To group items select 2 or more items and choose Edit > Group.

Groups can be nested to any level so groups can be part of other groups.

To ungroup items select the group and choose Edit > Ungroup. Any settings specific to the group (for example actions) will be discarded.

Stacking Order and Ovelapping

Stacking order defines how items overlap each other. Items on top will overlap other items.

Sending items behind

Select 1 or more items and choose Edit > Send to Back. The item will hide behind other items.

Bringing items to front

Select 1 or more items and choose Edit > Bring to Front. The item will be placed on top and overlap other items.

Master (Template) Frames and Items

To create a frame with shared objects choose "Movie" gt; "Add Master Frame" and place shared objects on the Master Frame. Master objects will appear beneath other items. To bring master items to front select the master item, choose "Item" > "Placement Properties" and change Layer to "Layer 1" or any layer above "Base layer".